PosgreSQL 11 Tile Release Notes

This topic provides release notes for Crunchy PostgreSQL for Pivotal Cloud Foundry (PCF) Tile.

v05.1113.015

Release Date: August 24, 2021

Notable software features in this release:

  • [Software Component Update] PostgreSQL v11.12-1 updated to v11.13-1
  • [Software Component Update] Support Software Updates

    • PgAudit Set User 2.0.0 -> 2.0.1

Additional notes about this release:

  • This release addresses critical vulnerabilities in PostgreSQL and PgAudit Set User. This upgrade is strongly recommended. Further information on these CVEs are available here: CVE-2021-3677 CVE-2021-38140

v05.1112.014

Release Date: May 27, 2021

Notable software features in this release:

  • [Software Component Update] PostgreSQL v11.11-1 updated to v11.12-1
  • [Software Component Update] Support Software Updates

    • postgres-common 225 -> 226

Additional notes about this release:

v05.1111.013

Release Date: March 05, 2021

Notable software features in this release:

  • [Software Component Update] PostgreSQL v11.10-1 updated to v11.11-1
  • [Software Component Update] Support Software Updates

    • postgres-common 222 -> 225
    • PgAudit 1.3.1 -> 1.3.2
    • Crunchy Backrest 2.27 -> 2.32
    • mysql common / mysql client 5.7.32 -> 5.7.33
    • libjasper1: 1.900.1-debian1-2.4ubuntu1.2 -> 1.900.1-debian1-2.4ubuntu1.3
    • libpoppler58: 0.41.0-0ubuntu1.14 -> 0.41.0-0ubuntu1.16
    • libssl1.0.0: 1.0.2g-1ubuntu4.17 -> 1.0.2g-1ubuntu4.18
  • [New Software Feature] Crunchy Backrest logs split into local and s3 folders
  • [New Software Feature] standalone plan Crunchy Backrest configuration file location now matches cluster plans

Additional notes about this release:

  • This release addresses critical vulnerabilities in PostgresSQL. This upgrade is strongly recommended. Further information on the CVE is available here: CVE-2021-3393

v05.1110.012

Release Date: December 01, 2020

Notable software features in this release:

  • [Software Component Update] PostgreSQL v11.09-1 updated to v11.10-1
  • [Software Component Update] Support Software Updates

    • postgres-common 215 -> 222
    • consul 1.7.2 -> 1.7.9
    • consul-template 0.20.0 -> 0.22.1
    • mysql common / mysql client 5.7.31 -> 5.7.32
    • libdbi-perl_1.634-1build1 -> libdbi-perl_1.634-1ubuntu0.2
    • libopenjp2-7_2.1.2-1.1+deb9u3build0.16.04.1 -> libopenjp2-7_2.1.2-1.1+deb9u5build0.16.04.1
    • libssl1.0.0_1.0.2g-1ubuntu4.16 -> libssl1.0.0_1.0.2g-1ubuntu4.17
    • libsystemd-dev_229-4ubuntu21.28 -> libsystemd-dev_229-4ubuntu21.29

Additional notes about this release:

v05.1109.011

Release Date: September 10, 2020

Notable software features in this release:

  • [New Software Feature] Configure S3 URI Style, defaults to host-based URIs
  • [New Software Feature] Enable/Disable certificate verification of SSL/TLS S3 connections

v05.1109.010

Release Date: August 31, 2020

Notable software features in this release:

  • [Software Component Update] PostgreSQL v11.08-1 updated to v11.09-1
  • [Software Component Update] Support Software Updates

    • postgres-common 214 -> 215
    • pgbackrest 2.15.1 -> 2.27
    • ODB-SDK 0.24.0 -> 0.39.0
    • mysql common / mysql client 5.7.30 -> 5.7.31
    • libc 2.23-0ubuntu10 -> 2.23-0ubuntu11.2
    • libjpeg-turbo 1.4.2-0ubuntu3.3 -> 1.4.2-0ubuntu3.4
    • libssl 1.0.2g-1ubuntu4.15 -> 1.0.2g-1ubuntu4.16

v05.1108.009

Release Date: May 29, 2020

Notable software features in this release:

  • [Software Component Update] PostgreSQL v11.07-1 updated to v11.08-1
  • [Software Component Update] Pivotal Stemcell (170.x to 621.x)
  • [Software Component Update] Support Software Updates

    • postgres-common 211 -> 214
    • python-certifi 2019.6.16 -> 2020.4.5.1
    • python-click 7.0 -> 7.1.2
    • python-configparser 3.7.4 -> 3.8.1
    • python-flask 1.0.3 -> 1.1.2
    • python-flask-httpauth 3.3.0 -> 4.0.0
    • python-idna 2.8 -> 2.9
    • python-jinja 2.11.1 -> 2.11.2
    • python-psycopg2 2.7.7 -> 2.8.5
    • python-requests 2.22.0 -> 2.23.0
    • python-urllib3 1.25.3 -> 1.25.9
    • python-werkzeug 0.15.4 -> 1.0.1
    • node-exporter 0.17.0 -> 0.18.1
    • consul 1.4.4 -> 1.7.2
    • cf_cli 6.49.0 -> 6.51.0
    • pgloader 3.6.1 -> 3.6.2
    • postgres-exporter 0.4.7 -> 0.8.0
    • wal2json 1.0 to 2.2
    • bosh CLI 5.1.2 -> 6.2.1
    • prometheus 2.13.0 -> 2.17.2
    • mysql common / mysql client 5.7.29 -> 5.7.30
    • libsystemd-dev 229-4ubuntu21.27 -> 229-4ubuntu21.28

v05.1107.008

Release Date: Feb 25, 2020

Notable software features in this release:

  • [Software Component Update] PostgreSQL v11.06-1 updated to v11.07-1
  • [Software Component Update] Support Software Updates

    • postgres-common 210 -> 211
    • libjpeg-turbo 1.4.2-0ubuntu3.1 -> 1.4.2-0ubuntu3.3
    • libmysqlclient 5.7.27-0ubuntu0.16.04.1 -> 5.7.29-0ubuntu0.16.04.1
    • libsystemd-dev 229-4ubuntu21.22 -> 229-4ubuntu21.27
    • mysql-common 5.7.27-0ubuntu0.16.04.1 -> 5.7.29-0ubuntu0.16.04.1
    • python-jinja2 2.10.3 -> 2.11.1

v05.1106.007

Release Date: Dec 18, 2019

Notable software features in this release:

  • [Software Component Update] PostgreSQL v11.05-1 updated to v11.06-1
  • [Software Component Update] Support Software Updates

    • postgres-common 204 -> 210
    • postgis25 2.5.0-1 -> 2.5.3-2
    • pgaudit95 1.0.7-0 -> 1.0.7-1
    • pgaudit10 1.2.1-0 -> 1.2.1-1
    • pgaudit11 1.3.1-0 -> 1.3.1-1
    • pgaudit_analyze 1.0.7-3 -> 1.0.7-4
    • set_user 1.6.2-0 -> 1.6.2-1
    • node_exporter 0.17.0-0 -> 0.17.0-1
    • postgres_exporter 0.4.7-0 -> 0.4.7-1
    • prometheus 2.7.1-0 -> 2.13.0-0
    • python_jinja2 2.8.1 -> 2.10.3
    • consul 1.4.4-0 -> 1.4.4-1
    • consul_template 0.20.0-0 -> 0.20.0-1
    • cf_cli 6.32.0-0 -> 6.32.0-1
    • haproxy 1.6.3-1ubuntu0.2 -> 1.6.3-1ubuntu0.3
    • libtiff5 4.0.6-1ubuntu0.6 -> 4.0.6-1ubuntu0.7
    • libgif7 5.1.4-0.3~16.04 -> 5.1.4-0.3~16.04.1
    • libgfortran 5.4.0-6ubuntu1~16.04.11 -> 5.4.0-6ubuntu1~16.04.12

v05.1105.006

Release Date: Aug 13, 2019

Notable software features in this release:

  • [Software Component Update] PostgreSQL v11.04-1 updated to v11.05-1
  • [Software Component Update] Consul Template structure updated.
  • [Bug Fix] Resolved consul-template pre-start overwriting issues.
  • [Software Component Update] Support Software Updates

    • postgresql-common 201 -> 204
    • libmysqlclient 5.7.26 -> 5.7.27
    • libpoppler 0.41.0-0ubuntu1.11 -> 0.41.0-0ubuntu1.12
    • libsystemd-dev 229-4ubuntu21.15 -> 229-4ubuntu21.22
    • mysql-common 5.7.26 -> 5.7.27
    • pgbackrest 2.14 -> 2.15.1

v05.1104.005

Release Date: Jun 21, 2019

Notable software features in this release:

  • [New Software Feature] Secure TCP/IP Service Instance Connections via SSL
  • [New Software Feature] Support for Loggregator Metrics
  • [New Software Feature] PostgreSQL 11.4
  • [Software Component Update] Simplified instance creation, changed all previously mandatory parameters to optional. Services can be created without any extra parameters.

    • Database names, if not provided, will be generated programmatically at service creation time.
  • [Software Feature Update] Added support for specifying a third-party S3 endpoint for S3 PGBackRest.
  • [Software Component Update] Major restructure and update to documentation.
  • [Software Component Update] Support Software Updates
    • consul 0.6.4 to 1.4.4
    • consul-template 0.16.0 to 0.20.0
    • libmysqlclient 5.7.25 to 5.7.26
    • libopenjp2-7 2.1.2-1.1+deb9u2build0.1 to 2.1.2-1.1+deb9u3build0.16.04.1
    • pgbackrest 2.07-1 to 2.14-2
    • pgaudit-set-user 1.6.1 to 1.6.2
    • plr 8.3.0.17 to 8.3.0.18
    • postgres-common 199 to 201
    • postgresql 9.5.16 to 9.5.18
    • postgresql 10.7 to 10.9
    • python-certifi 2018.11.29 to 2019.06.16
    • python-configparser 3.5.0 to 3.7.4
    • python-flask 1.0.2 to 1.0.3
    • python-flask-oauthlib 0.9.4 to 0.9.5
    • python-httpauth v3.2.4 to v3.3.0
    • python-markupsafe 1.1.0 to 1.1.1
    • python-oauthlib-version 2.0.2 to 3.0.1
    • python-requests 2.21.0 to 2.22.0
    • python-requests-oauthlib 0.8.0 to 1.2.0
    • python-urllib3 1.24.1 to 1.25.3
    • python-werkzeug 0.14.1 to 0.15.4
    • wal2json 1.0-4 to 1.0-5
  • [Software Component Update] New Software Dependencies
    • postgresql 11.4
    • mysql-common 5.7.26
    • pgaudit11 1.3.1
    • postgis25 2.5.0

Additional notes about this release:

  • This release addresses a critical vulnerability in SCRAM verifier parsing. This upgrade is strongly recommended. Further information on this CVE is available here: PostgreSQL Announcement